Aktivní dlaždice se sama vypíná

Určeno pro zařízení s operačním systémem Windows Phone
Post Reply
Tambor
Posts: 7
Joined: 26.03.2012 14:30
Location: Praha

Aktivní dlaždice se sama vypíná

Post by Tambor » 26.03.2012 14:43

Používám Meteoservis (placenou verzi) na WP ... před několika dny se mi najednou vypnula aktivní dlaždice a už nejde zapnout ... když se jí pokusím v nastavení zapnout, tak se přepne do polohy zapnuto, ale asi za vteřinu se zase sama vypne :?
NOKIA Lumia 830; Windows 10 Mobile

User avatar
Radim
Site Admin
Posts: 463
Joined: 16.12.2008 18:59
Location: Opava
Contact:

Re: Aktivní dlaždice se sama vypíná

Post by Radim » 26.03.2012 15:07

Potřebuju vždy vědět verzi aplikace o které mluvíme.
Máš update na tu poslední tj. 1.50?

Tambor
Posts: 7
Joined: 26.03.2012 14:30
Location: Praha

Re: Aktivní dlaždice se sama vypíná

Post by Tambor » 26.03.2012 16:46

Ano mám 1.5 , ale zrovna teď se mi to podařilo vyřešit. Musel jsem ve své Lumii 800 v nastavení vypnout a zapnout povolení k běhu na pozadí pro tuto aplikaci. Tvářilo se to sice, že je aplikace povolena, ale asi to bylo nějaké kousnuté .... Všechno už běží jak má ;)
NOKIA Lumia 830; Windows 10 Mobile

User avatar
Radim
Site Admin
Posts: 463
Joined: 16.12.2008 18:59
Location: Opava
Contact:

Re: Aktivní dlaždice se sama vypíná

Post by Radim » 26.03.2012 17:20

Hm, to je sice fajn, ale něco je zjevně špatně. Aplikace by při svém spuštění měla vždy "běh na pozadí" re-inicializovat. Jedinou "oficiální" možností by bylo, kdybys Meteoservis nespustil cca. 14 dní, tak by došlo vypnutí automaticky (vlastnost OS). Ale jelikož jsi už zkoušel v aplikaci změnit nastavení (což nešlo, jak jsi psal), tak se už aplikace spustila ale přesto se běh na pozadí nezinicioval správně apod.
No zkusím udělat pár testů, jelikož se mi toto chování OS nelíbí...

EDIT: takže jak zjišťuji, pokud sám uživatel a nebo OS (z jakýchkoliv příčin) běh na pozadí zakáže, takže tam není zaškrtnuto "povolit při příštím spuštění aplikace", nelze to z prostředí samotné aplikace změnit a je nutno to tedy vždy provést ručně v onom systémovém nastavení Úloh na pozadí. :?

Tambor
Posts: 7
Joined: 26.03.2012 14:30
Location: Praha

Re: Aktivní dlaždice se sama vypíná

Post by Tambor » 26.03.2012 17:44

... a asi nejsem jediný komu se to stalo, protože jsem si všiml, že i v marketplacu si v recenzích někdo stěžuje na stejný problém ... jinak aplikaci samozřejmě spouštím i několikrát denně ... je vážně dobrá ;)
NOKIA Lumia 830; Windows 10 Mobile

User avatar
Radim
Site Admin
Posts: 463
Joined: 16.12.2008 18:59
Location: Opava
Contact:

Re: Aktivní dlaždice se sama vypíná

Post by Radim » 26.03.2012 17:47

Paradoxní je, že to mám u sebe na své Omnii7 spuštěné pořád a za celou dobu se mi prostě nic podobného nestalo. Opravdu to vypadá na nějaký OS zádrhel.
A ještě se zeptám, nedošlo při tom "výpadku" taky k tomu, že se jakoby ztratilo nastavení aplikace Meteoservis? Že to vypadalo, jako když by se aplikace zrovna/poprvé nainstalovala?

Tambor
Posts: 7
Joined: 26.03.2012 14:30
Location: Praha

Re: Aktivní dlaždice se sama vypíná

Post by Tambor » 27.03.2012 08:41

Tak a je to tu zase. Na noc jsem si dal telefon do módu letadlo a ráno byla dlaždice vypnutá a nešla zapnout. Znovu jsem musel v nastavení telefonu vypnout a zapnout povolení k běhu na pozadí a potom už šla dlaždice normálně spustit .... Myslíš, že to může mít něco společného s tím "letadlem"?
NOKIA Lumia 830; Windows 10 Mobile

User avatar
Radim
Site Admin
Posts: 463
Joined: 16.12.2008 18:59
Location: Opava
Contact:

Re: Aktivní dlaždice se sama vypíná

Post by Radim » 27.03.2012 09:00

Mod Letadlo by toto způsobovat rozhodně neměl. Ostatně sám to tak provozuju už několik měsíců, každý den přepínám na noc do FlightMode a nikdy se mi nic podobného nestalo.
Potřeboval bych abys vysledoval, pokud se situace bude opakovat, aspoň toto:

- nedošlo při tom "výpadku" taky k tomu, že se jakoby ztratilo nastavení aplikace Meteoservis? Že to vypadalo, jako když by se aplikace zrovna/poprvé nainstalovala?

- na stránce nastavení v Meteoservisu, v sekci kde se zapíná LiveTile (dlaždice), je vždy dole uveden "Stav služby". Potřeboval bych vědět (přesně) co tam bylo napsáno. Tj. co tam bylo, když jsi po té "kolizi" aplikaci spustit a chtěl dlaždici zapnout a taky co se tam objevilo po (neúspěšném) zapnutí.

Díky

Tambor
Posts: 7
Joined: 26.03.2012 14:30
Location: Praha

Re: Aktivní dlaždice se sama vypíná

Post by Tambor » 27.03.2012 09:56

- tak asi se to vrátilo do původního nastavení, protože např. počet načítaných snímků je teď 4 a já tam měl nastaveno 12 ...

- v nastavení dlaždice bylo dole napsáno "Stav služby: vypnuta"
NOKIA Lumia 830; Windows 10 Mobile

User avatar
Radim
Site Admin
Posts: 463
Joined: 16.12.2008 18:59
Location: Opava
Contact:

Re: Aktivní dlaždice se sama vypíná

Post by Radim » 27.03.2012 12:57

No to je právě dost divné. Nastavení aplikací by se normálně "ztrácet" nemělo.
Pokud se tak stalo z nějakého důvodu stalo, je celkem jasné, proč Meteoservis resp. služba na pozadí stávkovala.

Podobné problémy (a nejenom s Meteoservisem) má zřejmě vícero lidí.
Mrkni se třeba tady: http://smartmania.cz/forum/viewtopic.php?f=136&t=28850
a nebo zde: http://smartmania.cz/forum/viewtopic.ph ... 35#p250163
a další příspěvky.

Jak jsem psal i jinde, je těžké toto "chování" nasimulovat či ověřit. Navíc se to u mne ještě ani jednou (za skoro rok) neprojevilo. Další možností samozřejmě zjišťuji a pokud na něco (já nebo někdo jiný) přijdu tak se tím určitě budu zabývat a řešit to dál.

User avatar
Radim
Site Admin
Posts: 463
Joined: 16.12.2008 18:59
Location: Opava
Contact:

Re: Aktivní dlaždice se sama vypíná

Post by Radim » 29.03.2012 14:55

Takže po proběhlém testování, jehož cílem bylo zjistit, jak by se choval Meteoservis, pokud by došlo ke ztrátě (souboru) nastavení jsem zjistil, že v tom případě má opravdu samotná aplikace problém se "znovu-zapnutím" služby na pozadí pro LiveTile. Problém byl ve způsobu vyhodnocování "aktuálního stavu" služby resp. zda je povolena LiveTile atd. Takže problém byl svým způsobem i v samotné aplikaci a už brzo připravím opravnou verzi (současně s podporou pro Tango update).

Detaily:
Test proběhl smazáním souboru __ApplicationSettings, který nastavení aplikace obsahuje a jenž je vytvářen "automaticky" prostřednictvím objektu IsolatedStorageSettings. Jeho smazáním jsou použity výchozí hodnoty nastavení, co je identické s prvním spuštěním aplikace.

Nicméně to pořád nevysvětluje (a neřeší) problém s tím, že se opravdu nastavení aplikace (tj. soubor __ApplicationSettings) ztratí a/nebo je resetován apod. Proč (a kdy) se tak děje je zatím stále záhadou.
Podobnou záhadu resp. problém řeší třeba zde: http://forums.create.msdn.com/forums/p/ ... 05301.aspx

Post Reply